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� Day 1

� What is Medicinal Chemistry?

� What is Cheminformatics?

� What is Virtual Screening?

� What is Molecular Docking?

� Molecular Docking Algorithms

� Molecular Docking using DOCK6.3

� Hands on: UCSF Chimera an Extensible Molecular Modeling System

� Day 2

� A Practical Guide to DOCK 6.3
� Hands on

• Preparing Molecules for Docking
• Generating Spheres
• Generating the Grid
• Rigid and Flexible Docking

AgendaAgenda
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General OverviewGeneral Overview

http://www.msi.umn.edu/~cpsosa/Apps_Center/AllApplications.htm
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Medicinal ChemistryMedicinal Chemistry
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Medicinal ChemistMedicinal Chemist

� “In Medicinal Chemistry, the chemists 
attempts to design and synthesize a medicine 
or a pharmaceutical agent that will benefit 
humanity.  Such a compound could also be 
called a ‘drug’, but this is a word that many 
scientists dislike because society views the 
term with suspicion.”

►Graham L Patrick, An Introduction to Medicinal Chemistry
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What Are Drugs?What Are Drugs?

� Drugs are compounds that interact with a biological 
system to produce a biological response

� No drug is totally safe
►Drugs have side effects

� The dose level of a compound determines whether it 
will act as a medicine or a poison

� A therapeutic index is a measure of a drug’s 
beneficial effect at low dose versus its harmful 
effects at higher dose
►High therapeutic indicates a large safety margin between 
beneficial and toxic doses

Graham L Patrick, An Introduction to Medicinal Chemistry
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Where Do Drugs Interact?Where Do Drugs Interact?

� Drugs act in at 
different locations

� Drugs target: 
►Lipids

►Carbohydrates

►Proteins

►Nucleic Acids

Image source: http://nobelprize.org/nobel_prizes/medicine/laureates/1999/press.html

Graham L Patrick, An Introduction to Medicinal Chemistry
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Drug InteractionDrug Interaction

� Drugs interact 
with 
macromolecules 
in a process 
called “binding”

� The area in the 
macromolecule 
where it takes 
place is the 
binding site

Drug interaction process

Macromolecule
Drug

Graham L Patrick, An Introduction to Medicinal Chemistry



99

Binding Binding MaltotriosoMaltotrioso

Chimera animations: http://www.cgl.ucsf.edu/chimera/tutorials/movies09/moviemaking.html
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CheminformaticsCheminformatics
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CheminformaticsCheminformatics

� Cheminformatics or chemical informatics:
► Computer and informational techniques

– “Chemoinformatics is the mixing of those information 
resources to transform data into information and 
information into knowledge for the intended purpose of 
making better decisions faster in the area of drug lead 
identification and optimization.” F. K. Brown

► Utilized by pharmaceutical companies in the 
process of drug discovery

Source: http://en.wikipedia.org/wiki/Cheminformatics
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Virtual ScreeningVirtual Screening
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Virtual ScreeningVirtual Screening

�Virtual screening:
►It is a computational technique used in drug 
discovery

►It involves the rapid in silico assessment of large 
libraries

►It is used to identify top structures that bind to 
a drug target

– Protein receptor or enzyme

http://en.wikipedia.org/wiki/Virtual_screening



1414

Screening TechniquesScreening Techniques

� There are two broad categories of screening 
techniques:
►Ligand-based

– Given a set of structurally diverse ligands that binds to 
a receptor, a model of the receptor can be built based 
on what binds to it

• Pharmacophore models

– Chemical similarity analysis methods to scan a database 
of molecules against one active ligand structure

►Structure-based

– Structure-based virtual screening involves docking of 
candidate ligands (small molecules) into a protein target

http://en.wikipedia.org/wiki/Virtual_screening
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Why Virtual Screening?Why Virtual Screening?

� It is crucial when testing from hundredths to 
millions of compounds

� It is also crucial when testing multiple 
targets

� Low cost compared to experiment
� Faster compared to experiment
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Speed and AccuracySpeed and Accuracy

�Objective of virtual screening:
►Fast method to identify top small molecules as 
potential drug candidates

►Accurate, capable of reproducing  
crystallographic Ligand-target complexes
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Molecular DockingMolecular Docking
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Molecular DockingMolecular Docking

� It is a computer 
simulation used to try 
to predict optimal 
conformations between 
a small molecule and a 
receptor
►Ligand-protein complex

►Binding site
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Computers in Drug DiscoveryComputers in Drug Discovery

Image source: http://en.wikibooks.org/wiki/Proteomics/Proteomics_and_Drug_Discovery
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Selected Molecular Docking PackagesSelected Molecular Docking Packages

� DOCK: Ewing, T.J.; Makino, S.; Skillman, A.G. and Kuntz, I.D. 
(2001) J. Comput. Aided Mol. Des., 15(5), 411-428.

� AUTODOCK: Morris, G.M.; Goodsell, D.S.; Halliday, R.S.; Huey, 
R.; Hart, W.E.; Belew, R.K. and Olson, A.J. (1998) J. Comput. 
Chem., 19(14), 1639-1662.

� GOLD: Verdonk, M.L.; Cole, J.C.; Hartshorn, M.J.; Murray, C.W. 
and Taylor, R.D. (2003) Proteins, 52(4), 609-623.

� FLEXX: Rarey, M.; Kramer, B.; Lengauer, T. and Klebe, G. (1996) 
J. Mol. Biol., 261(3), 470-489.

� ZDOCK: Chen, R.; Li, L. and Weng, Z. (2003) Proteins, 52(1), 80-
87.

� M-ZDOCK: Pierce, B.; Tong, W. and Weng, Z. (2005) 
Bioinformatics, 21(8), 1472-1478.

� MS-DOCK: Sauton, N.; Lagorce, D.; Villoutreix, B.O. and 
Miteva, M.A. (2008) BMC Bioinformat., 9, 184-196.

� Surflex: Jain, A.N. (2003) J. Med. Chem., 46(4), 499-511.
� MCDOCK: Liu, M. and Wang, S. (1999) J. Comput. Aided Mol. 
Des., 13(5), 435-451.
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Initial Requirement: Target & LibraryInitial Requirement: Target & Library

�Target Databases:
►RCSB Protein Data Bank (PDB)

►Worldwide Protein Data Bank (wwPDB)

►PDBBIND

►PLD

►AffinDB

►BindDB
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Initial Requirement: Target & LibraryInitial Requirement: Target & Library

�Small Molecules Databases:
►ZINC

►PubChem

►ChemDB

►DrugBank
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Algorithm OverviewAlgorithm Overview

� Search for the best fit or best arrangement 
between two or more molecules

� This search depends on several parameters:
►Input coordinates ( ligand and receptor )

►Geometrical complexity

►Atomic van Der Waals radius and charges

►Ligand/receptor flexibility

►Interatomic interactions

� Result: predicted orientation of the ligand with the 
target (pose) + binding affinity (ranking top 
candidates)
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Algorithms Used for Searching in Molecular Algorithms Used for Searching in Molecular 
DockingDocking

� Classification:
►Rigid-body docking method

– Does not take into account the flexibility of the ligand
nor the target

►Flexible docking method

– Takes into account the flexibility of the ligand or both
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Root Mean Square Deviation (RMSD)Root Mean Square Deviation (RMSD)

� “The root mean square deviation (RMSD) or root 
mean square error (RMSE) is a frequently-used 
measure of the differences between values 
predicted by a model or an estimator and the values 
actually observed from the thing being modeled or 
estimated. “

http://en.wikipedia.org/wiki/Root_mean_square_deviation



2626

Search AlgorithmsSearch Algorithms
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Fast Shape Matching (SM)Fast Shape Matching (SM)

� SM algorithms are based on the geometrical overlap 
between two molecules

� Rigid-body docking applications such as ZDOCK 
relies on SM algorithms
►Protein-protein docking simulations

� MS-DOCK also utilizes SM algorithms to reduce the 
initial size of the library

� DOCK uses this approach to identify of all possible 
binding sites ( sphere centers )

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Incremental Construction (IC)Incremental Construction (IC)

� IC algorithms divide the ligand into 
fragments

�Each fragment is treated separately
� It is used to treat ligand flexibility
�Docking packages using this approach:

►DOCK

►FLEXX

►FLOG

►Surflex

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Monte Carlo Simulations (MC)Monte Carlo Simulations (MC)

� This algorithm attempts to dock the ligand inside 
the binding site through many random positions and 
torsions

� Number of possible conformers of the ligand in the 
binding site is based on stochastic methods

� ICM and MCDOCK used this method.
� ICM: Abagyan, R.A., Totrov, M.M., and Kuznetsov, 
D.A. (1994) ICM: A New Method For Protein 
Modeling and Design: Applications To Docking and 
Structure Prediction From The Distorted Native 
Conformation J. Comp. Chem. 15, 488-506. 

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Simulated Annealing (SA)Simulated Annealing (SA)

� Docking conformations are carried into a simulation 
as a function of temperature

� Normally SA is more time consuming that other 
methods
►Annealing cycle is repeated for each ligand at the receptor 
site

� Filtering is required to minimize computational time
� Autodock combines SA and MC

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Distance Geometry (DG)Distance Geometry (DG)

� It uses information that can be expressed through 
intra- and intermolecular distances

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Evolutionary Programming (EP)Evolutionary Programming (EP)

� Computational models of evolutionary natural 
processes to resolve problems

� Genetic operators are utilized to simulate the 
permanence of the most favorable features

� EP is a heuristic algorithm

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Genetic Algorithm (GA)Genetic Algorithm (GA)

� EP-type algorithms that try to find the exact or 
closest conformation to the global energy minimum

� GOLD and DOCK use this type of algorithms
� Lamarckian algorithms are used in Autodock

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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TabuTabu Search (TA)Search (TA)

� TS is an iterative method designed to obtain 
solutions in an optimization procedures

� TS docking tend to be highly accurate

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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Some Docking ProgramsSome Docking Programs

ICFLOG

SMM-ZDOCK

ICFLEXX

ICSurflex

GAGOLD

MCICM

MCMCDOCK

SMMS-DOCK

SMZDOCK

ICDOCK

GAAutoDock

Search MethodProgram

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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What is a Scoring Function?What is a Scoring Function?

� Mathematical approximation for estimating binding 
affinity

� Tool for lead optimization in virtual screening
� Used in localization of protein unidentified binding 
sites

� Scoring functions estimate free energies of binding

► ∆∆∆∆G = ∆∆∆∆H - T∆∆∆∆S

Source: R. Dias and W. Filgueira de Azevedo Jr, “Molecular Docking Algorithms”, Current Drug Targets, 2008, 9, 1040-1047 and references therein
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What is virtual screening? What is virtual screening? 

Small molecule 

library

Target

X-Ray structure

Prepare Target

Rigid-docking

Top ranking 

molecules
Flexible-docking

Top ranking 

molecules

Further

refinement

Molecular DynamicsZINC

PDB
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Molecular Docking Using DOCK 6.3Molecular Docking Using DOCK 6.3
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DOCK HistoryDOCK History

� Original DOCK

►Rigid-docking combined with molecular graphics 
(by I. Kuntz, et al., 1982)

� DOCK 3.0: 
►Molecular Mechanics force filed scoring

� DOCK 3.5: 
►Energy minimization

� DOCK 4.0: 
►Ligand conformational flexibility

� DOCK 5.0→DOCK 6.1 → DOCK 6.2 → DOCK 6.3: 
►Ported to C++
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Target PreparationTarget Preparation

�X-RAY Structures
�Structures from other sources
�Generating matching points
�Grid construction
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LigandLigand PreparationPreparation

� Conformation
�Electrostatics
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ChimeraChimera

http://www.cgl.ucsf.edu/chimera/
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UCSF CHIMERA HomeUCSF CHIMERA Home
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Chimera UserChimera User’’s Guides Guide

http://www.cgl.ucsf.edu/chimera/docs/UsersGuide/index.html
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Lab: What Are You Going to Learn?Lab: What Are You Going to Learn?

�Manipulate PDB files within Chimera
►Manipulation, Selection, and Chains

►Select Structures

►Adding Labels

►Adding Color

►Molecular Representations and Surfaces

►Display Styles
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Lab: Obtain PDB FilesLab: Obtain PDB Files

� Where do you get the PDB file?

� The following PDB files are required:
►1ABE = L-arabinose-binding protein 

►1d86 = D(CGC[E6G]AATTCGCG)-NETROPSIN COMPLEX 

►1zik = GENERAL CONTROL PROTEIN GCN4 
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Lab: Open ChimeraLab: Open Chimera

1. Open Chimera ( on Windows, double click the 
Chimera icon )

2. Now open a structure
1. Choose File→ Open from the menu 

2. locate 1zik.pdb (the File type should be set to all (guess 
type) or PDB)

3. Use the Favorites menu to show the Side View
1. Try moving the eye position (the small square) and the 

clipping planes (vertical lines) with the left mouse button

2. Try moving the structure with the mouse in the main 
graphics window

3. Hovering the mouse cursor over an atom or bond (without 
clicking any buttons) will show identifying information in a 
pop-up "balloon." The balloon will disappear when the 
cursor is moved away   
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Lab: Select StructuresLab: Select Structures

1. Selection specifies atoms, bonds, residues, etc. for 
subsequent operations with the Actions menu.
1. Selection include using the Select menu or picking from 

the screen

2. Actions menu applies to whatever is selected, but when 
nothing is selected, the Actions menu applies to 
everything 

► Hide the water (red dots): 

► Select→Structure → solvent
Actions → Atoms/Bonds → hide

► Clear the selection and display only the chain trace: 

► Select → Clear Selection
Actions → Atoms/Bonds →backbone only → chain trace
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Lab: Select Structures from the ScreenLab: Select Structures from the Screen

� Picking from the screen is done by: 
►Clicking on the atom or bond of interest with the 
left mouse button while holding down the Ctrl 
key.

►To add to an existing selection, also hold down 
the Shift key

►Try picking two atoms, one from each peptide 
(Ctrl-click the first, Ctrl-Shift-click the second). 
The selection is highlighted in green, and its 
contents are reported on the button near the 
lower right corner of the main window
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Lab: Adding LabelsLab: Adding Labels

Label the atoms you have selected, first by atom name 
and then by residue name and number: 

� Actions→Label → name
Actions → Label → off
Actions → Label → residue → name + specifier

Each residue label is of the form: 

►res_name res_number.chain One peptide is chain A and 
the other is chain B. 

Clear the selection and undisplay the residue labels: 

� Select → Clear Selection
Actions → Label → residue → off
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Lab: Adding ColorLab: Adding Color

Color the two chains different colors: 
� Select → Chain → A
Actions → Color → cyan

Repeat the process to color chain B yellow. 

Display its full backbone: 
� Actions → Atoms/Bonds → backbone only → full

Display all atoms of chain A only: 
� Actions → Atoms/Bonds → show only

Display all atoms and color them by element: 
� Select → Clear Selection
Actions → Atoms/Bonds → show
Actions → Color → by element
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Lab: Exit ChimeraLab: Exit Chimera

� File → Quit
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Lab: Molecular Representations and SurfacesLab: Molecular Representations and Surfaces

� File → Open. 
► 1d86.pdb.  It contains the molecule netropsin bound to double-

helical DNA

� Undisplay the water: 
� Select → Structure → solvent
Actions → Atoms/Bonds → hide

� Color the different nucleotides different colors. For example, 
color the adenine deoxynucleotides blue: 

� Select → Residue → DA
Actions → Color → blue

� Analogously, color cytosine deoxynucleotides (DC residues) 
cyan, guanine deoxynucleotides (DG residues) yellow, and 
thymine deoxynucleotides (DT residues) magenta. Clear the 
selection with 

� Select → Clear Selection
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Lab: Display StylesLab: Display Styles

Try some different display styles, or representations. 
Multiple styles can be combined with each other and 
with surfaces (more on surfaces below) 

� Actions → Ribbon → show
Actions → Ribbon → edged
Actions → Ribbon → rounded
Actions → Ribbon → hide
Actions → Atoms/Bonds → stick
Actions → Atoms/Bonds → sphere

Change the representation of only one of the DNA 
strands: Select → Chain → A
Actions → Atoms/Bonds → stick
Select → Clear Selection

Change everything to a ball-and-stick representation: 
Actions → Atoms/Bonds → ball & stick
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Lab: Select Lab: Select LigandLigand

Ctrl-click to pick one of the atoms in netropsin
Label the residue: 
� Actions → Label → residue → name

►Showing that it is named NT

►The residue label might not be near the selected atom. 
The first submenu under Label controls individual atom 
labels, while the second controls residue labels. Actions →
Label → name would have shown the name of the atom 
instead of the name of the residue

Clear the selection and undisplay the residue label: 
� Select → Clear Selection (or Ctrl-click in empty 
space) 
Actions → Label → residue → off
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Lab: Playing with SurfacesLab: Playing with Surfaces

Have some fun with surfaces. There are built-in 
categories within structures such as main and ligand; 
when nothing is selected, Actions → Surface →
show displays the surface of main

� Actions → Surface → show
Actions → Surface → hide
Select → Structure → ligand
Actions → Surface → show
Actions → Surface → mesh
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Thank You!
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Appendix: Mouse ManipulationAppendix: Mouse Manipulation

� The X axis is horizontal in the plane of the screen, the Y axis is vertical in the 
plane of the screen, and the Z axis is perpendicular to the plane of the screen. 
By default, using a three-button mouse (although fewer buttons can be workable), 
models are: 

� rotated with the left mouse button in the graphics window. Rotation is about the 
X and/or Y axis when the cursor is in the central region of the graphics window 
(the cursor becomes a small circle) and about the Z axis when the cursor is in the 
periphery of the graphics window (the cursor becomes two curved arrows in yin-
yang configuration). The center of rotation can be adjusted with the Rotation tool
or the command cofr

� XY-translated with the middle mouse button (the cursor will look like a cross 
formed by two double-headed arrows). On Windows, depending on the mouse 
setup, an adjustment may be required. 

� scaled with the right mouse button (the cursor will look like a diagonal double-
headed arrow enclosing a small square); movements downward and/or to the right 
increase the scale, whereas movements upward and/or to the left decrease it. 
Interactive scaling can also be performed by rolling a mouse's scroll wheel or by 
dragging the small square in the Side View horizontally

� Z-translated with Ctrl-middle mouse button (the cursor will look like a vertical 
double-headed arrow); movements downward and/or to the right translate 
structures closer, and movements upward and/or to the left translate structures 
farther away. Note that Z-translation is not the same as scaling 


